Orange Pi

The Orange Pi are a series of embedded computer boards, similar to the Raspberry Pi. They are cheaper and are available in a number of variants.

OpenBSD on Orange Pi

As of OpenBSD 6.2 the H3 based boards are supported as part of the armv7 hardware platform. Sort of.

As of OpenBSD 6.3 the Orange Pi PC 2 is supported. The PC 2 is an H5 based board, so it is part of the arm64 hardware platform.

First you need to get the serial console working. It's 3.3v so you'll need a 3.3v to RS232 converter or a USB serial adapter that does 3.3v TTL. The console is 115200 8 N 1.

I've used TTL to RS232 adapters powered from the Orange Pi 3.3v on the IO connector. This worked in most cases, although one adapter was prone to passing gibberish from time to time. I think it was a 5v only adapter and was barely working on 3.3v. Others I've used worked fine.

The USB to TTL serial adapters I've tried all worked with three connections to the debug serial connector.

H3 armv7

As per the instructions in INSTALL.armv7 and hints from the internet, make a copy of a suitable miniroot, modify it in accordance with INSTALL.armv7, and write it to an SD card. You will need the u-boot-arm and the dtb packages to get the device tree file. For the Orange Pi One I did the following.

This should get you a bootable SD card that starts the installer. Install as normal.

No HDMI or video. Ethernet works, buy no WiFi.

USB works. I've used USB disk with no problems, and USB network adapters.

I have used this to set up an Orange Pi One, an Orange Pi Zero, and an Orange Pi PC.

H3Droid

There is an Android implementation for the Allwinner H3. H3Droid runs on most of the Orange Pi boards.

H5 arm64

Installing onto the Orange Pi PC 2 is very similar. You'll need the dtb and the u-boot-aarch64 packages.

The major difference with arm64 is multiprocessor support. The Orange Pi PC 2 has four functioning cores, instead of the one available with the armv7.

Once the boot media is done, insert it into the PC2 and boot it. Remember, it defaults to a serial console. Perform the OpenBSD install as usual.

To use HDMI out, create /etc/boot.conf containing the line:

set tty fb0

This tells the kernel to use the frame buffer as the console. You can also run X. To get X running on startup:

doas rcctl enable xenodm

Packages

Packages on the mirrors are named differently to the install:

To make the package manager easy to use, set the PKG_PATH environment variable to something useful in your .profile, e.g.

PKG_PATH=https://ftp.openbsd.org/pub/OpenBSD/7.3/packages/aarch64/
export PKG_PATH

Armbian Linux on Orange Pi

Armbian on Orange Pi is easy and works well. Just download the correct image, copy it to an SD card, install the card and power it up.

It does serial console over USB, so you can connect to it over the USB.

It supports the serial debug connector, so you can connect over TTL serial.

The install also gets the network going on the built in ethernet using DHCP, so you can connect via SSH if you find the IP address.

Finally, if you're using an Orange Pi with HDMI, you can plug in a keyboard and mouse to the USB and a monitor to the HDMI. Sometimes this is a bit fiddly getting the HDMI resolution and frequency correct, but it does work.